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Getting
Started

In this Chapter
¬¬
¬¬
¬¬
¬¬
¬¬
¬¬

Imagine...
The Idea Behind HyperStudio
Meet Addy!
Starting HyperStudio
Helpful Vocabulary
Life Beyond the Manual

HyperStudio 5

HyperStudio gives you control over the computer screen, rather than
the computer screen having control over you. That’s what makes
HyperStudio so much fun!
This chapter will introduce you to HyperStudio’s guide dog, named
“Addy”, and will explain some of the conventions used throughout the
Tutorial manual.
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Imagine...
A “Memory Box” that you could take photos out of, and that would then
explain themselves.
Making your own stop-frame animation movies.
A comic-book page that had movies in the frames and that was interactive
with the reader.
Giving a presentation based on objects in a scene, rather than reading
slides.
A tour of a past or present location using Google Earth, but controlled by
your own project, and with your own video commentary.
Making your own postcards for printing, or electronic postcards with
movies and your own spoken messages.
A handy paint program for common image manipulation tasks. Create
layouts for graphic design projects, and even make the layout interactive.
Writing animated stories or documenting historical events with your own
recorded videos.
A “digital scrapbook” of a trip or family event.
A “video badge” for a conference or other event instead of just a “name
badge”
A multiple-path story where user choices affect the outcome.

You can do all these and more with HyperStudio!
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The Idea Behind HyperStudio
With HyperStudio you’ll create cards. A series of cards is called a stack. Your
project can be a single stack or many stacks which have been linked together.

You can use the paint tools to draw on the background of the card. You can also
add pre-drawn art and photos.

You can add text objects and type on the card or put in from other sources.
Moreover, you can add text written in literally any language you want.

Buttons are hot spots on cards where you click with the mouse to make things
happen.

You can add sound to the card. Record your own voice, use the prerecorded
sounds which come with HyperStudio, or play sounds and tracks you have
stored on your computer directly in your projects.

You can show clips from your video projects directly in your HyperStudio stacks
and even record your own movies. You can even place a live video object on
your card to show live video.

You can add pictures from your hard disk, CD or DVD discs, the Internet, or the
HyperStudio collection.

HyperStudio 5

Page 7

Tutorial

Chapter 1 — Getting Started

Meet Addy!
HyperStudio is a very “conversational” program. You’ll have your very own
personal guide, Addy, as you use the program.

For example, in other programs, you may have noticed that when you begin
a new document with the menu item “New”, you’re soon staring at a blank
screen without even an explanation of what happened, or what to do next! In
HyperStudio, the first time that you start a new stack, Addy appears to tell you
what’s going on. Throughout the program, Addy will appear in dialogs to help
you out and guide you along your way. However, Addy is also a polite guide, and
so you’ll notice that most of the dialogs have an option allowing you to skip them
if you wish. Addy also knows that people have different personalities. She wants
to be sure that you’ll get everything that you want out of this manual and the
program, and knows that there are different styles of learning to use a program. If
you are the orderly-sequential type, you’ll like the step-by-step instructions in this
Tutorial for creating a project about sailing, which starts in Chapter 3.

On the other hand, if you’re the exploratory type, then HyperStudio is rich
with possibilities for experimentation and discovery. If you prefer the “explorer
approach”, you can start off by just browsing the Reference Guide to get a general
idea of what’s available, and then start building your own stacks! If you get to a
situation where you’re uncertain as to what to do next, return to the Reference
Guide for a quick refresher on how a certain feature works, or search for new
features you might have missed in your first reading.
With either approach, once you have become comfortable with the basics of
HyperStudio, be sure to read the Tips in Chapter 3, the Advanced Techniques in
Chapter 4, and the Ask Addy section in Chapter 5 where we’ll show you things
that will make you an even better HyperStudio user!
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Starting HyperStudio
The Basic Materials

To get started with the software, you should make sure that you have everything
you need in place. To begin this Tutorial, you should have installed the
HyperStudio software on the hard disk of your computer. If you haven’t installed
HyperStudio, see the Reference Guide for installation instructions.

Starting the Program

To start up HyperStudio, you should be looking at the files in the Applications
folder of your computer. If you have properly installed HyperStudio on your hard
disk, you should see the HyperStudio program icon. Double-click this to start up
the HyperStudio program.

Starting the HyperStudio program

Registering HyperStudio

Right after entering the registration number or clicking Trial, you will be asked to
register your copy of HyperStudio 5. If you do not register, you can register later
by choosing Register HyperStudio from the HyperStudio application menu. Just
follow the onscreen instructions that appear.

Why register?

At Software MacKiev, you’ll find that we like to keep our products up to date.
When you register, you can choose to be notified whenever we post a free update
or have a discounted upgrade available for a new edition.

HyperStudio 5
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HyperStudio Resources

When you start up the HyperStudio program, you’ll see a brief view of the
program title screen. After that, a stack which has been created for you to get
started will open.

The HyperStudio program is located on your hard disk and contains libraries of
pre-made artwork, sounds and movies that you will soon be using to create your
own projects!

Where to Start?

Before you even begin this Tutorial, we recommend that you indulge your own
curiosity, and explore HyperStudio on your own.

Don’t worry about getting lost! Whenever HyperStudio starts up, it looks for a
stack named “Home Stack”, and that’s just what you are seeing on your computer
now. You can think of this as a “home base”, to which you can always return
while using the software. There is even a special menu item for returning to these
screens. You’ll find it in the Go menu, where choosing Home will always bring
you right back to this Home Stack.
When you’re ready to make a stack yourself, use the text here in the Tutorial
to guide you, since you’ll be able to keep the book open in front of you as you
explore the software on the computer screen.

I Need a Break!

Remember, with HyperStudio, you’re in charge of the computer! HyperStudio
is very friendly! If you want to explore the project for a while, and then take a
break and come back later, just choose Quit HyperStudio from the HyperStudio
application menu. When you restart HyperStudio, it will go right back to the
Home Stack, from where you can resume your exploration, or you can dive
straight into the Tutorial!

I’m Ready to Learn!

If you’ve now spent some time exploring HyperStudio in general, you’re ready to
begin our “official” Tutorial!
There are some brief sections coming up that will prepare you with some tips on
how this manual is organized, and the words and phrases that you’ll be seeing a
lot of as you go through the text.
After that, in Chapter 2, you’ll be introduced to the paint tools in HyperStudio
because most cards have some kind of painted image on them.

Finally, Chapter 3 will take you through the creation of your first stack. It only
takes about an hour to learn all the basic elements of creating any HyperStudio
stack, and at the end of the chapter, you’ll be able to start making your own
projects!

Let’s go!

Page 10

HyperStudio 5

Tutorial

Chapter 1 — Getting Started

Helpful Vocabulary
Following the directions in this manual will be much easier if we agree on what
some of the words and phrases mean. Because this section is rather lengthy, you
may want to skip it now, and then return to it if you encounter unfamiliar terms in
the Tutorial. If you’ve used a computer before, you are already familiar with the
concepts of clicking, double-clicking, dialogs, etc. As a new HyperStudio user,
there are also terms such as “objects” and “buttons” that will be introduced in the
Tutorial, but which are also described here.
Here are the words and phrases that you’ll see a lot of in the upcoming pages:

Card:

When you create a HyperStudio project, it is a lot like working in a paint
program with multiple screens or pages. The term used in HyperStudio for
this is a card. You can imagine index cards with notes and drawings on them
that a lecturer might use, or perhaps the notion of cardboard panels held up
on an easel to an audience that are flipped through during a presentation.
Either way, it’s all as simple as just saying that each “page” in your project is
a card. (In case you’re wondering, the reason we don’t use the word “page” is
to distinguish HyperStudio from word processor programs, and because the
words “card” and “stack” — coming up next — have a long tradition in the
world of multimedia!)

Stack:

A collection of cards is called a stack, which you save in a single file on your
hard disk or on CD or DVD discs. You can also share stacks using the Internet!
A typical stack has 5-10 cards in it, although the HyperStudio software doesn’t
have any specific limit.

Project:

A project refers to the entire collection of stacks that make up the story you
are telling. A small project might consist of a single stack, which is saved and
worked with as a single file, but you can connect as many stacks together as
you wish. A typical project can contain anywhere from a few to hundreds of
stacks.

Background and Objects:

When you create any card in your stack, the simplest part of it is the
background that you can paint on using the paint tools, or add images to from
anywhere on your system. It is called the background because you can also
have objects, namely buttons, text objects, graphic and video objects, that you
can put “in front” of the background on your card. Objects cannot be erased
with the eraser tool or painted on with the paintbrush. They can, however,
be moved, edited, and deleted using the Arrow tool, which is specifically for
working with objects. The entire background is a continuous image, and parts
of it can be erased, re-painted, and otherwise changed with the paint tools.

HyperStudio 5
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You can also flatten selected objects to the background. This means they
become part of the background image and can only be edited as such.
Conversely, it’s also possible to create an image object from a selected area of
the background.
Understanding the difference between the background and objects is extremely
important to successfully using HyperStudio. While using the Tutorial, it is
well worth taking the time to experiment as much as necessary until you feel
comfortable with these parts of your work area.

Tool:

HyperStudio has specific tools for doing certain things. For example, if
you wanted to draw a square on the screen, you might not want to use the
Paintbrush (which is itself a tool), since you might get an uneven line. Instead,
you can use the Rectangle tool, which will draw a complete rectangle with just
a single mouse press, drag, and release.
Because dragging the mouse will do different things depending on which tool
you’ve chosen, it’s important to stay aware of which tool is currently active.
HyperStudio makes this easy to do, because the cursor changes its appearance
depending on which tool is active. The mouse cursor for the paintbrush is very
different than the mouse cursor that appears when you are typing text on the
screen, for example.

Select:

This word is used a lot in this manual! Selecting something is the action of
telling HyperStudio what you want it to deal with. Because the process of
selecting something is so important in the use of any program, we’ve broken
this down into the various situations that you are likely to come across:

• Parts of a card: There are times when you will want to select parts of the
card you are looking at. How you select it depends on just what it is that
you want to select, and whether it is part of the background painting on that
card or an object that can be repositioned at any time, acting as though it
was “in front” of the painted image on that card.

• Background images: If you want to select a part of a graphic image that you
are looking at, click one of the Selector tools, and then position the mouse
cursor slightly above and to the left of the part of the image that you want
to select. Hold down the mouse button while you drag down and to the right
of the area. We think it’s easier to grasp this concept if you imagine yourself
cutting out a piece of cloth with a picture on it. Instead of trying to cut the
picture precisely, you’d probably cut a rectangle that was just large enough
to hold the entire image. This is exactly how you use the cursor to select
an image, except that you don’t have to “cut” the four sides! This will be
explained in greater detail in the Tutorial, but the principle of selecting a
rectangle by dragging the mouse from one corner to the opposite corner is
used very often throughout HyperStudio.
• Objects: Objects in HyperStudio are either controls, graphics, movies, or
text objects. Select an object by clicking the Arrow tool in the Tools palette
and then clicking the object once with the arrow cursor. Once selected,
objects can be moved, edited, or deleted.
Page 12
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• An item in a list: You will often see a list of items, such as a list of visual
transition effects that can be used when going from one card to another. In
this kind of list, you can click an item to select it. This will cause the item
to be highlighted, showing you that it has been selected. If you change your
mind, simply click any other item in the list.

Text:

The idea of text is pretty obvious. You should be aware that letters can
be painted on the background of a card using the Text tool. Note that text
created this way has to be totally erased and repainted if you want to change
it. HyperStudio also supports text objects, which are like miniature word
processor windows, where the text you enter can be changed at any time by
just double-clicking inside the text object. The Tutorial will explain more
about this, but it’s important for you to remember the differences between
painted text and text objects.

Graphics:

A selected graphic
▲▲▲
Example of a selected graphic

Because HyperStudio is such a visual environment, the words graphics,
images, and pictures show up a lot. Like text, however, there are important
differences in just how you choose to put these things in your stack. A
picture file that you open or save to your disk is usually called a graphic file.
When you open a graphic file using the Add a Graphic command from the
Background menu, you place the graphic on the background of your card. It
becomes part of that background, and can be selected using the Selector tools,
and erased or moved at any time. You are editing the background image at that
point.
However, if you choose Add a Graphic Object from the Objects menu,
the image that you select becomes an object which is placed in front of the
background, and which can only be moved or deleted using the Arrow (Edit)
tool. Graphic objects cannot be changed using the Eraser, the Paintbrush, the
Square Selector, or any of the other paint tools.

Other Terms:

There are actually many terms used throughout the HyperStudio Tutorial and
Reference Guide, but these have been the ones that are the most often used,
and also the most important to you as you use the program. Remember that
the best way to master any concept is to try it! So, don’t rely so much on
the definitions here. The best way is to explore the program with your own
hands, and experiment as much as you need until you understand the concepts.
Remember, you really can’t hurt anything, and as much as anything else,
HyperStudio is about exploring your own creativity and having fun!

HyperStudio 5
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Life Beyond the Manual
Although it is our goal to make this manual as useful as we can, it is impossible
for one manual to cover everything possible with the software. In general, any
instructional text must balance how much information is presented, and in what
depth, with the patience of the reader. However, there is always more to learn.

Once you are using HyperStudio on a regular basis, there will be times when you
know what you want to see on a certain card in your project, but you don’t know
how to put it there. What should you do then?

Trust your Instincts...

First, try to say to yourself just what you expect to see on the screen. If you can
say the words for what you want to happen, very often you’ll have also described
how to do it!

For example, suppose you say, “I want a sound to play when the person using my
stack clicks this button.” You’ve actually given yourself a very good hint as to
where to start looking and experimenting, even if you don’t happen to remember
exactly what to do. If you know that a button is an object, you’d look in the
Objects menu (or just find it there by hunting through the menus) or the Library
palette. Once you choose Add a Button, HyperStudio will automatically help you
make a button on the card, and very soon you’ll see the “Play a sound” action in
the Things to Do list.

Even though you didn’t know how to make a button play a sound when you
started, you have found the right way to do it just by following your intuition, and
been helped along by the way you said in your head what you wanted to happen.
But what if simple hunting around doesn’t give you the answer you want? The
next step is to look in the Reference Guide in the general chapter that you think
might apply to what you want. In our example, you would find a chapter called
“Sounds”, which tells you all the different ways that HyperStudio will record and
play sounds in your project. Again, following a good hunch will probably get you
to your answer very quickly.
Finally, the other place to look in the Reference Guide is also probably the most
obvious: the Index. There are many entries in the index that go beyond simple
chapter titles and section headings. In many cases, you’ll find an answer, like
“Text objects” in the most direct way possible.

Experiment... and Practice!

However, there are times when even the Reference Guide doesn’t have the
answer, and many times this is when a combination of features are used to achieve
a result. There isn’t an easy answer here, but then again, that’s also part of the
satisfaction of any creative tool: using your own ingenuity to make things happen
that no one has even thought of before!
Like other creative tools, HyperStudio will become more powerful in your hands
the more you use it. You’ll find that as you practice using it to make different
projects, you won’t be able to keep yourself from thinking of neat new ways to
accomplish different effects in a project.
Page 14
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A Final Thought

Remember, there is rarely just a single way to accomplish something in
HyperStudio. Your own creativity will lead you to fascinating and rewarding
solutions to the challenges you set for yourself.

In the end, the real measure of your project is, “Did I tell my story effectively?”
The goal of your efforts is to share your ideas and experiences with others in a
way that pleases you, and gets the point across as directly as possible.

You can be confident that HyperStudio is the best software in the world for just
that task, and is used and enjoyed by more people for that purpose than any other
program!
Here at Software MacKiev, we’ll keep working to keep it that way!

Enjoy!

HyperStudio 5
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Chapter 2

The Paint
Tools

In this Chapter:
¬¬
¬¬
¬¬

Helpful Tips
The Tools Palette Illustrated
A Practice Activity

HyperStudio 5

This chapter will help you become familiar with the paint tools in
HyperStudio. The step-by-step tutorial in Chapter 3 for creating a
project on Sailing assumes that you are comfortable with the mouse,
the drawing tools, and the selector tools. If you haven’t used a paint
program before, you should spend some time experimenting with the
different tools.
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Helpful Tips
Showing the Tools Palette
Slider for switching between Background
and Objects modes

¬¬
¬¬
¬¬
¬¬

HyperStudio has a floating Tools palette that can be placed next to the card
that you’re working on, or anywhere else you like, and from which you can
easily choose any of the paint tools that you wish to use.
To show the Tools palette, choose Show Tools from the Window menu.
Once the Tools palette appears, you can reposition it on the screen by
dragging the title at the top of the palette.
To hide the Tools palette, click the small cross button in the title bar of the
palette.

About HyperStudio 5 Modes

In HyperStudio 5, there are two drawing modes available — Background mode
and Objects mode. In Background mode, everything you draw or add to a card
is flattened to the background and cannot be edited as a separate object (it can
only be edited as part of the background image). Conversely, everything you add
in Objects mode can be edited (deleted, rotated, scaled, and so on) any time you
need.
¬¬ To enter Background mode, drag the slider in the Tools palette so you can
see the word “Background”.

¬¬
▲▲▲
The Tools palette

Tips About the Shift Key

¬¬

Pressing the Shift key while you draw with the Pencil tool

¬¬

If you press the Shift key while you use the Spray Can
paint in a straight line!

¬¬
¬¬
¬¬
¬¬
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To enter Objects mode, drag the slider in the Tools palette so you can see the
word “Objects”.

Paintbrush

or the

is a little trick for drawing straight lines!
, you can spray

If you press the Shift key while you use the Eraser
straight line!

, you can erase in a

Pressing the Shift key while you use the Line tool
vertical or horizontal lines, or lines at an angle of 45°.

will draw only

Pressing the Shift key while you use the Oval tool

will draw circles.

Pressing the Shift key while you use the Rectangle tool
Rectangle tool

or Rounded

will draw squares.
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Tip About the Selector Tool

Once you choose the Square Selector tool from the Tools palette, your cursor will
change to a crosshair. To use the Square Selector tool, position the cursor at the
top-left corner of the area you want to select, press the mouse button, drag the
mouse diagonally down to just past the lower right-hand corner of the area, and
release the button. When something is selected, you’ll notice a red dotted line
outlining the selection. If you didn’t select the area properly, you can click outside
the dotted line to turn it off and try again.

The selected area will also have handles at all its corners and an additional
right-side handle. You can resize the selected area by dragging any of the corner
handles, and rotate it by dragging the side handle. Remember that clicking outside
the selected area after resizing or rotating will flatten this area to the background.
You can undo your changes by using the Undo command from the Edit menu or
by pressing Command-Z on your keyboard.

Different Lines, Colors, and Paintbrushes

¬¬
¬¬
¬¬

You can choose different line thicknesses and colors for your lines,
rectangles, and ovals in the Tools drawer located at the bottom of the Tools
palette.
Using the Tools drawer of the Tools palette, you can choose different colors
for the currently selected tool.
You can also choose a different brush shape in the Tools drawer of the Tools
palette.

Tips on How to Erase the Background

To erase painted images or text, you have several options:
¬¬ Use the Eraser tool.

¬¬
¬¬

¬¬

Use the Square Selector, Circular Selector, or Lasso tool. Select the part
you’d like to erase and press the Delete key.
Immediately after you draw something, you can choose the Undo command
from the Edit menu, or use the keyboard shortcut, pressing ⌘-Z. (While you
hold down the ⌘ key, press the letter Z once.) Try drawing a line and right
after that pressing ⌘-Z. You can undo as many actions as you need.
In the Tools drawer for the Eraser tool, click Erase Background. This will
erase your whole background and make your card the color you select.

Tip on Deleting Objects

¬¬

HyperStudio 5

Use the Arrow (Edit) tool. Click the object you want to delete, or drag across
several objects you want to delete and press the Delete key.
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Tip on Painting Text

Before clicking away from text created with the Text tool in Background mode,
you can edit the text, use the Delete key, and choose a different color, size, and
font in the drawer for the Text tool. Once you move the cursor away from the text
and click, the text becomes “painted” onto the background (flattened), and you
lose the ability to easily make changes to that text. Therefore, it’s a good idea to
check your text carefully before clicking. If you want to add text that you can edit
at any time, use the Text tool in Objects mode. You will be learning about using
text objects for text that can be easily edited in the practice activity, later in this
chapter.
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The Tools Palette Illustrated
Browse Tool
Activate objects and buttons with their attached actions
(movement, sound, etc). Use this tool to test actions and
run the stack.

Arrow (Edit) Tool
Click this tool and then edit or
move objects on the card.

Mode Switch
Drag this slider to switch
between Background and
Objects modes. See page 18.

Circular Selector
This tool lets you capture
an oval area. Circular or
oval pictures can be used
as buttons or cameo-style
photos.

Square Selector
This tool lets you capture a
rectangular area. Then you can
copy, cut, delete, move, rotate,
or resize it.

Lasso
Draw around a shape with
the lasso and it will hug the
shape so you can copy it,
cut it, delete it, move it, or
resize it.

Paintbrush
Draw freehand using one of
many different brush shapes.

Paint Bucket Fill Tool
Use this fill tool to color a
closed shape.

Eraser
Set the eraser color and erase.

Spray Can
Scatter lots of tiny dots or
objects with this tool.

Rectangle
Use this tool to draw rectangles
and squares.
Oval
Use this tool to draw ovals
and circles.
Text Tool
Paint text on a card or add
a text object with this tool.
Magnifying Glass
Zooms you in closer. All the paint tools
work there too, so you can do really
detailed work.

HyperStudio 5

Pencil
Draw freehand.
Line Tool
Draw straight lines.
Rounded Rectangle
Use this tool to draw
rounded rectangles and
squares.

Effects
Use this tool to apply special
effects to a background or to a
graphic object.
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A Practice Activity
This activity will give you a little practice with the paint tools. Follow the
instructions to produce a card like the one illustrated to the left.

This activity assumes that the options in HyperStudio Preferences are set as
follows:
¬¬ The “Use a double click to modify content in Edit mode” option is selected
in the General pane.

¬¬
¬¬
▲▲▲
The finished card after completing
the practice activity

The Animation and Image Crop options are turned off in the General pane.
The “Provide coaching hints” option is selected in the Assistance pane.

To Begin:

qq

qq

From the File menu, choose New Stack. This will give you a blank card on
which you can create this project.

The File menu

Click Continue in the hint about changing the card size that appears.

Hint about changing the card size for a new stack
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qq

Click Continue in the “New stack” hint.

Hint about creating a new stack

To Change the Color of the Card:

qq

qq

From the Background menu, choose Erase Background.

The Background menu

The Erase Background screen appears.

The Erase Background screen

HyperStudio 5
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qq

Choose the cream color at the bottom of the palette of sample background
colors and click Erase Background. The color you have selected becomes the
background color and the color for the Eraser tool.

Preview of Card 1 after erasing the background

In the future, if you wanted to choose a particular color, you could also click the
“Custom” box to bring up the Colors palette. Alternatively, you can click the
Eraser tool in the Tools palette, open the Tools drawer, select a color and click
Erase Background. To see the Tools drawer, click the small triangle at the bottom
of the Tools palette, or double-click the tool you want to use.
You can also use the Paint Bucket Fill tool to fill the card background with a
color. In this way, the color of the Eraser stays unchanged. Just click the Paint
Bucket Fill tool, pick a color for it in the Tools drawer (click the small arrow at
the bottom of the Tools palette), and then click the card.

To Draw a Border:

qq
qq
Click the arrow
to open or close
Tools drawer

qq

Then click the Rectangle tool
in the Tools palette. The cursor changes
to a crosshair. (If you cannot see the Tools palette, choose Show Tools from
the Window menu. The Tools palette appears.)
In the Tools drawer, drag the Size slider to the second thickness marker and
click a dark blue color. To see the Tools drawer, click the small triangle at the
bottom of the Tools palette, or double-click the tool you want to use. (So, in
our example, double-click the Rectangle tool.)
Using the crosshair, begin in the top-left corner of the card and drag
diagonally down to the bottom-right corner to create a border.

▲▲▲
The Rectangle tool with its settings in
the Tools drawer
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qq
qq

Choose a lighter blue color and draw a second border inside the first one
so that the outside edges of the new border touches the inside edges of the
previous one.
Choose a bright orange color and draw a third border inside the other two
touching the edges of the second border.

Preview of Card 1 after adding borders

To Paint Text in Background Mode:

qq
qq
qq

Make sure you are in Background mode. See page 18 for more details.

qq

The cursor has changed to a text cursor. Click the card to position the
insertion point in the place where you want to begin typing. Be sure to leave
enough room for the cursor to clear the border you have drawn. Set the
cursor down one half inch to the right of the border and two inches below it.

qq

Click the Text tool

in the Tools palette.

In the Tools drawer, choose the American Typewriter 36 font, select the Bold
style, and click a blue color.

Type “If you are a police dog,” press Return to get to a new line, and type
“where’s your badge?”

▲▲▲
The Text tool with its settings in the
Tools drawer

HyperStudio 5
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qq

Preview of Card 1 after adding text

Check your spelling before you click away from the text. In Background
mode, you cannot use the Delete key to delete letters once you click away
from this text, because the text will have become part of the background.

To Move the Painted Text in the Background Mode:

qq

qq
qq
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Use the Square Selector tool to reposition the text. To do this, drag a
rectangular area around the quote. The selection will be surrounded by the
dotted line. When you move your cursor over the selection, it will turn into
a hand. Drag the selected area to its new position, and then click outside the
dotted line to place the selection.
In the Tools drawer for the Text tool, select the Georgia 24 font, an orange
color, and the Italic and Bold styles. Using the Text tool, type “James
Thurber”.
Position the name in the lower-right corner of the card.
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That’s it! You are ready to start a HyperStudio project
We will not save this card.

HyperStudio 5
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To:

Remember:
¬¬

You can make a new selection by clicking somewhere else on the card to
turn off the dotted line, and then try again.

¬¬
¬¬

The Circular Selector is a great tool for creating cameo-style pictures.

¬¬

Move the cursor carefully across the dotted line. Wait for it to become the
hand before you drag the mouse to move or copy the image.

¬¬
¬¬
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Pressing Shift will make the Circular Selector select circles.

When you lasso something, any part of the selection that is the same color
as the background surrounding the selection will become transparent. For
example, if you lasso a yellow school bus with white windows on a white
background, the windows will be transparent.
To adjust the lasso sensitivity, drag the Sensitivity slider. When applied to
the freehand lasso, the Sensitivity slider defines how different in color a
pixel must be from the color of the pixel you click in order to be selected.
Dragging the slider to the left will set the tool to select only pixels that differ
significantly in color from the pixel you click.

¬¬

There are lots of brush shapes to choose from in the Tools drawer for the
Brush tool.

¬¬
¬¬

To spray a heavier concentration of dots, keep the mouse button pressed.
You can spray in a straight line by pressing the Shift key while you spray.
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To:

Remember:
¬¬

Aim the “hot spot” of the Paint Bucket Fill Tool in an enclosed area.

¬¬

You can erase against a straight edge by pressing Shift while you erase.

¬¬

There are different line sizes to choose from in the Tools drawer for the Line
tool.

¬¬

HyperStudio 5

The hot spot!

You can draw vertical, horizontal, or 45° lines by pressing the Shift key
while you draw.

¬¬

⌘ - click with the pencil to pick a color right off the screen, without
opening the Colors palette. This is like using the Eyedropper to pick up a
color.

¬¬

Pressing Shift will draw squares.

¬¬

Pressing Shift will draw circles.
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To:

Remember:
¬¬

Pressing Shift will draw squares with rounded corners.

¬¬

This tool is used to paint text in Background mode and add text objects in
Objects mode.

¬¬
¬¬
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In Background mode, you can change the text without any difficulty until
you click outside it.
Press Return to begin a new line.

¬¬
¬¬
¬¬

HyperStudio 5 can zoom in up to 800%.

¬¬

You can apply special effects to the card background and graphic objects.

All the paint tools work in Magnify mode.
Use the zoom pop-up menu in the bottom-right corner of the window to
change the magnification level.
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Chapter 3

Creating A
Project
In this Chapter:
¬¬
¬¬
¬¬

Before We Begin...
Project Overview
The Three-Card Project

HyperStudio 5

Follow the step-by-step instructions to create your first HyperStudio
project. You might want to refer to the tips and techniques on the lefthand pages even after you have become an experienced HyperStudio
user!
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Before We Begin...
Points to Ponder

It is impossible to overstate the enormity of changes in literacy and literacy
practices wrought by developments in electronic technologies. Because we can’t
comprehend what is happening, we search for apt metaphors, or for historical
examples which might serve to explain what is happening. So let me ask: “Are
we in the middle of a second Gutenberg revolution?” The answer is: “No, we’re
not”; what is taking place in the field of literacy is more far-reaching, and more
fundamental.
- Gunther Kress

Preface A-Z 21st Century Literacy Handbook

How to Use this Tutorial

Today’s computer experience is filled with a rich mixture of different forms
of information, from the photos and music tracks that accompany blogs and
personal online pages, to animations and videos, and a high degree of nonlinear interactivity with the “reader”. HyperStudio was one of the first “hyperlinked” media-rich creative environments. Today it is more effective than ever at
providing an extremely accessible and flexible environment for combining and
manipulating many different types of information media. The goal of this tutorial
is to learn the basic skills needed to use HyperStudio. By creating this project you
will learn how to use HyperStudio to assemble your own media-rich projects to
organize information, tell a story, and have fun in the process!

The right-hand pages are the action pages. Follow these directions carefully. Use the
little checkboxes (q) to keep track of what you have completed. The left-hand pages
are filled with “Tips and Techniques”. These will be referred to on the action pages.
Browse the tips as your interest dictates and then continue with the action pages.
This Tutorial assumes that the options in HyperStudio Preferences are set as
follows:

¬¬
¬¬
¬¬

The “Use a double click to modify content in Edit mode” option is selected
in the General pane.
The Animation and Image Crop options are turned off in the General pane.
The “Provide coaching hints” option is selected in the Assistance pane.

About this Project

You will be creating a three-card stack. We have chosen a project on Sailing, as
this touches on many possible themes: travel, business, family history, and school
projects. On the title card you will learn how to create a background. You will
also be adding a graphic, which will either be one provided in HyperStudio or
your own if you have your own graphics collection or digital camera. A button that
includes the sound of your voice will take you to Card 2. (You can see the number
of each card at the bottom of the window.) On the second card, you will add a
graphic of a sailing ship and assign an action to take you to Card 3.
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We will go back and add enhancements to Card 2 as your skills improve. On Card
3 you will add a text object with some text and several graphic objects of sailing
ships which will appear at a click of a phrase in the text object — a hypertext
link. You will also play a movie on Card 3 and then go to Card 2 to create an
animation.

A Word About Stack Design

This tutorial suggests only one method of creating a three-card stack. There isn’t
really an incorrect way to do this. As you use HyperStudio, you will develop your
own style. Whether you create several cards and then make the buttons to connect
them, or create the buttons along the way, will eventually be up to you.

Stacks can be linear, such as in a book where the cards are connected
sequentially. Other projects can use the branching method, where one card (like a
Table of Contents) connects to cards throughout the stack. A circular-style stack
might be used for projects which demonstrate cycles.

HyperStudio 5
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Project Overview
Card 1

¬¬
¬¬

The Circular Selector tool was used to
create this cameo-style photograph.
The “Let’s go sailing!” button will take
you to Card 2.

Card 2

¬¬
¬¬

Click the image of the sailing ship to take
you to Card 3.
Click the word “Sailing” (an invisible
button) to see it move across the card
and finally stop over the bottom of the
photograph.
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Card 3

¬¬
¬¬
¬¬

The background of this card has been
copied from Card 2 and pasted here.
Click the graphic to see the movie.
This text object contains the word
“sailing”. Clicking that word will display
other pictures of sailing vessels.

HyperStudio 5
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Tip #1: Changing Stack Settings

When you create a stack, you can change its settings. To do it, you need to follow
these simple steps. Note that you don’t need to change the stack settings to
proceed further, so information provided in this tip is optional.
1. From the Background menu, choose About This Stack (Fig. 2).

2. In the Inspector, specify the settings you want. (Fig. 4). For more
information on specific stack settings, see the HyperStudio 5 Reference
Guide or Help. The settings are applied as soon as you change them. If you
cannot see the Inspector, choose Show Inspector from the Window menu.

Tip #2: When an Area is Selected With the Selector Tool

¬¬
¬¬
¬¬

You can move the selected area by dragging it to a new position.

¬¬

You can resize the selected area by dragging one of its corners. (The cursor
will change to a two-headed diagonal arrow.)

¬¬
¬¬

You can erase the selected area by pressing the Delete key.
You can make a copy of the selected area by holding down the Option key
as you move it.

You can rotate the selected area by dragging the right handle of the selected
area.
You can place or drop the selected area on the card by clicking outside of
the selected area. Clicking outside an area without moving it just deselects
the area.

Tip #3: Made a Mistake?
¬¬ Choose Undo from the Edit menu, or press the Command key (⌘) and the
letter Z.
Tip #4: Adding a Picture to a Stack

HyperStudio gives you a choice of two sources for adding images to a card:

¬¬

You can add images from the HyperStudio collection, or from a file located
on your hard disk, a CD, or a digital camera. To choose a particular file
from your hard disk, choose Import in the image selection window, and then
click Choose. From there you can navigate to either a folder of images, or
a particular file, as you wish. If you have a USB connected digital camera,
you can access pictures directly on the camera.

Tip #5: The Circular Selector Tool and Perfect Circles

¬¬
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The Circular Selector tool will usually select an oval area. Hold down
the Shift key to select a circle. When selecting a smaller portion of a total
graphic image, use the Scale slider to “zoom in” on the area in which you
wish to work.
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The Three-Card Project
Beginning Your Project

qq From the File menu (Fig. 1), choose New Stack. This will give you the first
card on which you can start building your project. (See Tip #1, page 36.)

▲▲▲
Figure 1: The File menu

qq Click Continue in the hint about changing the card size that appears, and
then click Continue in the “New stack” hint. Choose About This Card from
the Background menu. In the Inspector that appears, type “Card 1” in the
Name field to rename the card.

Adding a Background

We will be importing a background called “Adventures”.

qq From the Background menu (Fig. 2), choose Add Background.

▲▲▲
Figure 2: The Background menu

qq In the dialog that appears, click All Categories in the Select a Category list,
choose “All Types” from the Show pop-up menu, and type “Adve” (you
don’t need to type the entire name) in the Search field at the top-right corner
of the dialog. The Adventures image will become highlighted in the dialog.
Alternatively, you can scroll to this image and click it.
qq Choose the “Stretch to fill card” option in the Layout group at the bottom of
the dialog and click Add to Card.
qq The Adventures image should appear filling Card 1.

Adding an Oval-Shaped Graphic

We will be adding a graphic image to the background from the HyperStudio Library
of graphics, but you could also add pictures stored on your hard disk, or even loaded
directly from a USB-connected digital camera (See Tip #4, page 36.)
▲▲▲
Figure 3: Crop Image dialog

A graphic added to the background is different from a Graphic Object that “floats”
in front of the background.

qq From the Background menu, choose Add a Graphic. (See Fig. 2.)

qq Choose “All Types” from the Show pop-up menu. In the Search field, enter
“treasure”. You should see “Treasure Map” in the Preview area. Click to
select it.
qq Click the Crop Image button at the lower left.

▲▲▲
Figure 4: The About This Stack pane of
the Inspector

HyperStudio 5

qq Click the Circular Selector in the dialog that appears and draw an oval
around the sailing ship in the lower-left corner of the map. Start a little to
the left and top of the ship and drag diagonally down and to the right until
you have an acceptable oval around the ship (See Fig. 3). If you need to try
again, click away from the dotted line to turn it off. (See Tip #5, page 36.)
You can adjust the selection area by dragging the handles that appear around
the selection.
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Tip #6: Painting Text With the Text Tool

¬¬

¬¬

You can edit text, use the Delete key, and change the color, size, and
font before you click away from painted text typed with the Text tool in
Background mode. Please check your spelling before you click away from
the last character you typed.
You can move painted text by selecting it with the Square Selector tool and
then dragging the selected image to a new position on the card.

Tip #7: Saving

¬¬
¬¬
¬¬
¬¬

Use Save As from the File menu when you want to make a backup under
another name.
Once you save, the stack name will appear at the top of your card.
After you have saved your stack, you can choose Save from the File menu or
use the keyboard shortcut ⌘-S to save any changes you make.
When you save your stack, you can make it be your Home Stack, so it will
automatically open the next time you launch HyperStudio 5. Just select the
“Set this stack as your Home Stack” option in the Save As dialog.

Tip #8: Adding New Cards to a Stack

¬¬
¬¬
¬¬
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When you add a new card to your stack, the one you were looking at will
seem to disappear. Don’t worry! Your other card(s) will still be there.
When you add a new card, it is added right after the card you are currently
looking at.
Your stack can contain an unlimited number of cards, but it is a better idea
to keep the number of cards within a stack manageable. Ten to fifteen cards
per stack is a good number. You can use buttons to link these smaller stacks
together, like chapters in a book (select the “Another stack” action from the
“Places to Go” category).
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qq Click Crop.
qq Choose the “Center at original size” option in the Layout group at the bottom
of the dialog and click Add to Card.
qq Use the resizing handles to make the ship about 50% larger, then drag the
picture toward the center area of the card.

Adding a Title to the Card

We will be painting a title on the background of this card.

qq In the Tools palette (Fig. 5), click the Text tool
▲▲▲
Figure 5: The Tools palette

.

qq Click the small arrow at the bottom of the Tools palette to open the drawer
and choose Apple Chancery, Size 75. You can also double-click “T” tool to
open the Tools drawer to the Tools options. Tip: typing “Apple” in the line
with the font name in the drawer will automatically help you select that font.
qq Click the Gradients tab in the Tools drawer, and then click the icon with
three gradient boxes in the top-right corner of the pane. The Colors palette
appears with the Gradients pane active. In the Colors palette, choose
Circular, and then select a shade of light blue for the “Inside” color and dark
blue for the “Outside” color. Click the Close button in the top-left corner to
close the Colors palette.
qq Move the cursor to the card. The cursor changes to a text cursor. Set the
insertion point on the card by clicking the card where you want the first
character. Allow enough space for the total height of the character you will
be typing. Begin one inch below the top of the border and two inches inside
it to the right.
qq Type the title “Sailing”. (See Tip #6, page 38.)

Saving Your Stack
▲▲▲
Figure 6: The Save As dialog

We’ll be saving the project on the Desktop.

qq From the File menu, choose Save As. (Fig. 1)
qq Select Desktop as the location. (You can drag the stack to a particular folder
later on.)
qq Name the stack Sailing (Fig. 6). Click Save. (See Tip #7, page 38.)

Adding a Second Card to Your Stack

qq From the Edit menu (Fig. 7), choose New Card. (See Tip #8, page 38.).
Click the Arrow tool.
qq Click Continue in the “New card” hint.

qq In the Inspector, type “Card 2” in the Name field to rename the card.
▲▲▲
Figure 7: The Edit menu

HyperStudio 5
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Tip #9: Moving Manually Through a Stack

There are menu items, keyboard shortcuts, navigation buttons, and a Card Index
which will allow you to move around in your stack.

¬¬

¬¬

¬¬
¬¬

The fastest way to move back and forth through the cards in your stack is to
use the keyboard shortcut for “next card” (Cmd-period) and “previous card”
(Cmd-comma). However, this is easier to remember if you notice that these
two keys also have the “<” and “>” characters on them. Thus, Cmd-< for the
previous card, and Cmd-> for the next card.
Card Index is located in the left side of the stack window. You can use Card
Index to go through your stack. Click the
button in the bottom-left
corner of the window to open Card Index, and then click a thumbnail to go
directly to the corresponding card.
There are also navigation buttons at the bottom of the HyperStudio 5
window. Click them to navigate between cards.
From the Go menu, you can choose: Back, which moves to the previous
card that you were looking at, regardless of position in the stack. Sort of like
moving backward in time. There is also Forward (if you just used Back and
want to move forward in the card history again). Home will take you back to
last card that you were on in the HyperStudio Home Stack (see the Reference
Guide for more information on this). Finally, there is Next Card, Previous
Card, First Card, Last Card, Jump to Card. There are keyboard shortcuts for
these menu commands as well. The good news here is that it’s pretty difficult
to get lost in a two-card stack!

Tip #10: Button Stuff

¬¬

Buttons are places on the screen where you click to make things happen.
When you create a button, HyperStudio wants to know three things:

1. What the button should look like.
2. Where you want it.
3. What it will do.

Tip #11: Help Messages When You Make an Object

¬¬
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When you create an object for the first time, HyperStudio will display a help
screen reminding you of the procedure. If you select the “Don’t show this tip
again” checkbox, you will not see this help screen in future.
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Importing a Background for the Entire Card

qq Choose Add Background from the Background menu (Fig. 2).

qq In the dialog that appears, click All Categories in the Select a Category list,
choose “All Types” from the Show pop-up menu, and type “Corkboard” in
the Search field in the top-right corner (Fig. 8). Select the Corkboard with
Notes image. Alternatively, you can just scroll to this image and select it.
qq Select the “Stretch to fill card” option at the bottom of the dialog and click
Add to Card.
qq The image should appear on Card 2.
▲▲▲
Figure 8. The Add a Background dialog

Moving Back to Card 1

qq To move back to the first card in the stack, choose Previous Card from the
Go menu. You can use the keyboard shortcut ⌘-,. (See Tip #9, page 40.)

Making a Visible Button to Connect Two Cards

We’ll be creating a button with an icon to link the two cards. We’ll then edit the
button (a useful skill) to add some sound.

qq To make a button, go to the Objects menu and choose Add a Button. (See
Tip #10, page 40.)

qq In the Inspector pane that appears, choose the Aqua Rounded Button (type
1) and click OK. Click Continue in the next screen. If the Inspector does not
appear, double-click the button.
qq Change the button’s name from “Button” to “Let’s go sailing!”.
▲▲▲
Figure 9. The Appearance pane in
the Inspector for a button

qq Select the “Show Icon” checkbox, and then click the Show Icon button to
choose an icon for the button (Fig. 9).
qq Scroll down and select the icon with the yellow right-pointing arrow. (Refer
to the illustration on page 34).
qq Click OK.

qq In the Inspector, click the Style icon to go to the Style pane, and change the
font to Apple Chancery, 14 point, black. Resize the button so that both the
name and icon fit.
qq Drag the button to center it in the bottom of the card.

qq In the Inspector, click the Actions icon to go to the Actions pane.

qq On the Places to Go side, click “Next card” (Fig. 10). This will automatically
take you to the Transitions pane where you can choose the visual effect you
want to use to take you to Card 2. (See Tip #12, page 42.)
▲▲▲
Figure 10: The Actions pane of
the Inspector

HyperStudio 5

qq Scroll down the list of transition effects and select the Cube transition. Then
click OK.
qq This will bring you back to the Actions pane (Fig. 10).
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Tip #12: Transitions

¬¬

You can create some really neat effects by using transitions with a button.
For example, you can have new text revealed if you use the Wipe Right
transition. Things can seem to appear magically when you use the Fade
transition.

Tip #13: Editing Buttons

¬¬
¬¬
¬¬
¬¬
¬¬

If you create a button and then want to move it, delete it, or change what it
does, you can use the Arrow tool.
Use the Arrow tool to edit a button and use the Browse tool to navigate your
way through a stack.
Be sure to switch back to the Browse tool after you have edited a button.
Pressing Ctrl-Tab will toggle back and forth between the Browse and Edit
(Arrow) tools.
See the Reference Guide for more information about the Browse, Arrow, and
other tools.

Tip #14: Recording Sounds

¬¬

It’s a good idea to be prepared with what you want to say before you click
the Record button.

Tip #15: Sample Sounds

¬¬

Sounds that show up in the list are stored in HyperStudio and can be found
in the Library palette.

Tip #16: Changing the Color of a Card

¬¬

You can erase the entire background to any color you wish by opening the
Background menu and choosing Erase Background.

Tip #17: The Map Button Tool

¬¬
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The map button tool is great for making irregularly shaped states, countries
and other shapes into buttons. It works in any place that you would be able
to use the Fill tool. An example where you might use this button tool is in
making the different colored areas of a beach ball into buttons.
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qq Click the Browse tool in the Tools palette and click your button to try it out.
You should end up on Card 2. Click the Arrow tool to return to Edit mode.
qq Once you get to Card 2, move back to Card 1. (Review Tip #9, page 40.)

Editing a Button

We’ll edit the button and add some sound to it.

qq To edit your button, select the Arrow tool in the Tools palette (Fig. 5). (See
Tip #13, page 42.)
qq Double-click the button you’ve added.
qq In the Inspector, click the Actions icon. This takes you to the Actions pane
(Fig. 10). If you cannot see the Inspector, choose Show Inspector from the
Window menu.

Playing a Sound

qq In the Actions pane, in the Things to Do list, select “Play a sound” and then
click the Record a Sound button.
qq Select the microphone you are going to use from the Audio Source pop-up
menu.

qq Click the Record button. You will see a three-second countdown, allowing
you to get ready to record. As soon as the countdown reaches the end, you
can start recording.

qq Speaking into the microphone, say “Let’s go sailing.” (See Tip # 14, page 42.)
▲▲▲
Figure 11: The “Play a sound” action

qq Click the Stop button to stop recording.
qq Click Play to listen to your recording.

qq Click OK. In the sound settings screen that appears (Fig. 11), click OK to go
back to the list of actions.
qq In the Tools palette, select the Browse tool (Fig. 5).
qq Click your button to go to Card 2.

qq Now is a good time to save your changes. (Review Tip #7, page 38.)

Adding a New Card With the Same Background
We’ll create a new card with the same background as Card 2.

qq Choose Ready Made Cards > Same Background from the Edit menu.

qq Choose About This Card from the Background menu, click Continue in
Inspector that appears and rename the card to “Card 3”.
qq Move back to Card 2.

Adding a Graphic Object
See Tip #18, page 44.

qq From the Objects menu, choose Add a Graphic Object.
HyperStudio 5
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Tip #18: Graphics and Text in Objects mode

¬¬

¬¬

In HyperStudio 5, there are two modes for drawing tools — Background
mode and Objects mode. In Background mode, everything you draw on a
card is flattened to the background and cannot be edited as an individual
piece of art once you click outside the card or select the Arrow tool. In
Objects mode, everything you add to the card becomes an object which can
be moved or edited whenever you want. You cannot erase objects added in
Objects mode with the Eraser tool. Graphic and text objects added in Objects
mode can be deleted with the Arrow tool. You can also use this tool to move,
resize objects and to edit their actions.
Some reasons you might want to add text or images as objects are:

1. They can be hidden and shown with the click of a button. (Hide or Show
Object action.)
2. Graphic objects can be made draggable with the Browse tool (as in
moveable puzzle pieces).

3. They can be used in stacks that use Group Cards, where you want to have
a common background but unique objects on each card. See the Reference
Guide for more information about group cards.
4. Since objects can be moved easily with the Arrow tool, they are more
convenient when you are working on a complex background. An example
of this would be using a text object created in Objects mode so that you
can easily move it over a card that has a photograph or other picture as the
background. Even a simple horizontal line can be a useful graphic element
when used as graphic object.

Tip #19: The Graphic Appearance Pane of the Inspector

¬¬
¬¬
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It is not necessary to name graphic objects unless you have more than one on
a card that will be addressed by an action.
You can select a frame for a graphic object if you wish.
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qq Go to the Transportation category, click the disclosure triangle, and select
Sea. Next, choose All Types from the Show pop-up menu, and then select the
“Boat” image.
qq Click “Add to Card”.

qq Drag one of the corners to resize this image according to the reference
illustration on page 34, and then drag the picture to the upper-left part of the
card, inside the photo frame. Click Continue in the Inspector pane.

Copying an Image From One Card to Another

We’ll be copying the boat image and pasting it onto another card.

qq Change to the Edit (Arrow) tool, and click the boat.
qq Choose Copy Image from the Edit menu.
▲▲▲
Figure 12: The navigation buttons in the
toolbar at the bottom of the window

qq Manually move to the next card by pressing ⌘-., or using the navigation
buttons in the bottom toolbar (Fig. 12).

qq Once you are on Card 3, choose Paste Image from the Edit menu and drag
the image to fit inside the frame on the left side of the white sheet of paper.

Linking Two Cards Using a Graphic Object

We’ll add an action to the graphic object to link the two cards.

qq Move back to Card 2.

qq Change to the Edit (Arrow) tool, and click the boat.
qq Click the Actions icon in the Inspector. In the Places to Go list in the Actions
pane, select “Next card”.
qq Scroll down the list of transition effects and select the Cube transition.
qq Click OK.
qq Click the Browse tool, and then click the boat image to test it.

Playing a Movie

Let’s play a movie on Card 3.

qq Move to Card 3 and click the Arrow tool to return to Edit mode.
qq Double-click the pasted object of the boat or choose Show Inspector from
Window menu while the boat graphic object is selected.
qq In the Actions pane, click “Play a movie or video”.
qq Click the “Disk or Network File” button (Fig. 13).
qq Click the Movies folder in the left part of the window that appears, scroll
down the list of movies and choose the Sailing Movie. Click Add to Object.
▲▲▲
Figure 13: The Inspector pane for
selecting a movie source

HyperStudio 5

qq The movie will float over the card waiting to be placed. Resize the movie to
fit the photo frame in the upper-left corner of the card. Drag it to the frame
and rotate a bit to correspond to the position of the frame.
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Tip #20: Text Objects

¬¬
¬¬

You can stretch or reduce the text object by dragging the resize handles
located at its corners. (The cursor will change to a two-headed diagonal
arrow.)
If you are in Browse mode, you’ll have to switch to the Arrow tool to stretch
or shrink the text object.

Tip #21: Changing the Color or Style of Text in a Text Object

¬¬
¬¬
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To change the color of all the text in the text object, use the Arrow tool
to select the text object, and then set the color of text you want in the
Appearance pane of the Inspector.

You can change the color of as many words or characters as you wish within
a text object. To do this, select the words you want to change by dragging the
cursor across them. Once the text is selected, select the new color you want
in the Style pane of the Inspector (Fig. 15).
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qq Click OK in the Inspector.
qq You can preview the movie in the Inspector by clicking the Play button. (See
Tip #23, page 48.)
qq After the movie has stopped, select the “Show first frame” checkbox and
deselect “Play over objects” checkbox. (Fig. 14)
qq Click OK.
qq In Browse mode, click the boat image to see the movie.
▲▲▲
Figure 14: The Inspector for Play a movie
or video action

Adding Clip Art

Let’s play the movie within a leather frame.

qq From the Objects menu, choose Add a Graphic Object.
qq Choose Masks from the “Show:” pop-up menu, select the Designs category
and then the Borders subcategory, and find Leather Frame.
qq Select the image and make sure “Scale to fill 1/3 of card” is also selected.
Click Add to Card.
qq Rotate using the rotation handle and resize the frame clip art to fit just over
the movie.

Adding Graphic Objects
See Tip #18, page 44.

qq From the Objects menu, choose Add a Graphic Object.
qq Click Transportation > Sea, choose All Types from the Show pop-up menu,
and then scroll down to the “Sail Away” image.
qq Select the image and make sure “Scale to fill 1/3 of card” is also selected.
Click Add to Card.
qq Drag one of the corners to resize the image, and then drag the object to one
of the film frames in the upper-right part of the card. Click Continue in the
Inspector pane.
qq Repeat the procedure described above for the “Sailing Ship Lynx” and
“Sailing Boat” images from the Transportation > Sea category by pasting
them into separate movie film frames.

Adding a Text Object

We’ll be adding a container for text, in which you can easily write and edit text as
well as import existing text.

qq Choose Add a Text Object from the Objects menu. A text object and a help
message will appear. Read the help text and click Continue.
▲▲▲
Figure 15: The Style pane of
the Inspector

HyperStudio 5

qq Drag the text object to the white sheet of paper near the image of the boat
you have added. (See Tip #20, page 46.)
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Tip #22: Ready Made Cards

¬¬

HyperStudio contains collections not only of art and sounds you can use,
but also predesigned cards. These Ready Made Cards act as templates for
individual cards that you would like to use over and over again.

Tip #23: Movie Tips

¬¬
¬¬
¬¬
¬¬
¬¬
¬¬
¬¬
¬¬

A movie can be added as an object action, where the user clicks an object
to play the movie, or as a card action, where the movie plays when the user
arrives at that card.
Select “Loop movie” when you want the movie to play continuously until
you leave the card.
Select “Show first frame” if you want the first frame of the movie showing
on the card.
Select “Play over objects” when you want the movie to play over a text
object, graphic object, or button.
Select “Use movie controller” if you want the user to be able to use the slider
to control the movie. You can pause the movie by clicking its frame.
Select “Erase when done” when you want the last frame of the movie to
disappear after the movie has played.
Click the Play button in the Inspector to preview your movie.
If you want a movie to dissolve and disappear after it has played, edit the
button which plays the movie. In the Inspector, choose “Another card” from
the Places to Go list of the Actions pane. Select the card that the movie is
on, and use the Fade transition. The button will now play the movie, then
take the user back to the same card, making it seem as though the movie is
melting away.

Tip #24: Creating an Animation Path

¬¬
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Release the mouse button to stop recording the animation path.
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qq Stretch the text object so that it fits to the background layout. (See the
illustration on page 35.)
qq Double-click the text object and type a paragraph according to the reference
illustration on page 35.

Adding a Hypertext Link

We will now make a link out of the word “Sailing” which will display other
pictures of sailing vessels.

To let users know which words are hypertext links, it is a good idea to underline
those words. To change the color or font of selected words or the whole text, see
Tip #21, page 46.

qq To select the word, drag the cursor across the word “Sailing” in the text
object.
qq From the Objects menu, choose Hypertext Links.
▲▲▲
Figure 16: Hypertext Link

qq The Inspector appears and the word “Sailing” will appear in the Hypertext
Link field. Click the Add button (Fig. 16).
qq Click the Actions button.
qq In the Actions pane (Fig. 10), in the Things to Do list, select “Hide or Show
Object” (Fig. 17).
qq Select the checkboxes next to the “Sail Away”, “Sailing Ship Lynx”, and
“Sailing Boat” graphics in the list of objects.
qq In the Effects column, choose Show from the pop-up menu next to each
selected graphic object.
qq Click OK in the Hide/Show pane, and then click Go Back in the Actions
pane.

▲▲▲
Figure 17: Hide or Show Objects Action

qq Save your stack.
Note: As the graphic objects are already shown, clicking this button will
just refresh the view of these objects. What we will do is create a card action
associated with this card that will hide the graphic objects when arriving at
the card.

Giving an Action to Hide Objects When Arriving at the Card
qq From the Background menu, choose About This Card.

qq In the Inspector, in the “Things to do when” area, select the “arriving at
card” checkbox.
qq Choose Hide or Show Object.
qq Select the checkboxes next to the “Sail Away”, “Sailing Ship Lynx”, and
“Sailing Boat” graphic objects in the list.
HyperStudio 5
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Tip #25: The Animation Settings

¬¬
¬¬

¬¬

¬¬
¬¬
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You can change the speed of the animation using the “Move” pop-up menu
in the Path Options pane of the Inspector.
In the Animation Options pane, select “Transparent color” if you want to
make a color contained in your animation transparent. For example, a hot air
balloon might be flying across the card. If you wanted the area in between
the ropes to be transparent, you would select “Transparent color” and use the
eye-dropper to pick a color from the image.
Once your animation is recorded, you will probably want to erase the
original artwork that the animation was created from. This will prevent the
original from remaining on the screen while the animation plays. Be sure to
select “Show first frame” if you want the user to see the first frame of the
animation upon arrival to the card.
An instance where you’d select “Erase when done” might be if you were
showing a car driving into a garage.
If you need your animation to end in a specific spot, begin your animation
on that spot and create the animation backwards. Once it is done, click the
“Start here” button in the End area of the Path Options pane of the Inspector.
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qq In the Effect column, make sure that the Hide option is selected for each
graphic object.
qq Click OK, and then click Go Back.
qq Save your stack.
Notice that the graphics in the movie film are now hidden when you are in
Browse mode. Test your Hypertext link by clicking the word “Sailing”. The
graphics should appear.

Animating the Word Sailing

We’ll write the word “Sailing...” on the card and create a button to make the word
fly across the card.

qq Move back to Card 2.

qq In the Tools palette, drag the mode slider so that the word “Objects” appears.
You are now in Objects mode. Double-click the Text tool in the Tools palette.
qq In the Tools drawer, choose the Verdana font, set the text size to 18, deselect
Italic, and set the text color to red. Click the third tab in the drawer for the
text tool and deselect the Drop Shadow checkbox.
qq Position the cursor over the pink sticky paper at the bottom right side of your
card, click once and type the word “Sailing...”. Click the Arrow tool, and
rotate the text object a bit.
qq Choose Add a Button from the Objects menu.

qq In the Inspector, select the Invisible Button. It is shown as a dotted rectangle.
Click OK, and then click Continue.
qq Position the button over the word Sailing and resize it so that it covers the
pink sticky paper. Choose Send to Back from the Layout menu.
qq In the Actions pane (Fig. 10), in the Things to Do list, select “Play
animation”. The Inspector changes its appearance.
qq Click the Part of the Card button.

qq Click the Selectable Object button.
qq Click the “Sailing...” text object.
qq The word “Sailing...” becomes the cursor. Create the path for the animation
by holding down the mouse button and dragging the cursor along the path
you want the animation to follow until it is under the photo frame in the
upper-left corner of the card. Release the mouse button and click Continue in
the Inspector. (See Tip#24, page 48.)

▲▲▲
Figure 18: The Animation Options pane

HyperStudio 5

qq You can preview your animation by clicking the Play button in the Inspector.
You can also speed the animation up, slow it down, select a new graphic, and
re-record or edit the animation path. (See Tip #25, page 50.)
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Tip #26: Using Gradients

¬¬

Imagine having a border on a card. You can fill the center area with a
gradient:

1. Select the Lasso tool, hold down the Option key, and click somewhere
within the white area. This will turn the lasso into an expanding lasso and
select all of the inner white area.

2. When you see the dotted line, choose Effects, and then Image Effects from
the Edit menu. Click “Gradients”.

¬¬

3. Create a gradient pattern and then click OK to apply it.

You can also use the gradient effect to fill small, hard to fill areas, such as a
mosaic type pattern.

1. Lasso the area.

2. Choose the same color for the “Top” and “Bottom” of the gradient and then
click OK.
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qq Make sure that the “Show first frame” checkbox is selected so the image of
“Sailing...” appears on the card before it is animated.
qq Click OK in the Animation Options pane of the Inspector.

qq To avoid having a double image of the animation, simply delete the text
object you have animated from the card. Use the Arrow tool to select the
“Sailing...” text object, and press the Delete key to erase it. The “Show first
frame” of the animation will provide this text.
qq Test your button by changing to the Browse mode, and clicking the word
“Sailing...”.
qq Save your stack.

Adding a Buton that Leads to the Home Stack

We’ll be adding a button that closes your Sailing stack and opens HyperStudio
Home Stack when activated.
qq Choose Show Library from the Window menu.

qq In Library, click the Objects icon, and then click the Custom Buttons folder
in the pane that opens.

qq Scroll down the list of custom buttons until you see the brown round button
with a home icon on it. Drag this button to the card and place it in the
bottom-left corner of the card. Click Continue in the Inspector.

qq In the Places to Go list in the Actions pane, select “Home Stack”. Scroll
down the list of transition effects and select the Sky Clouds transition. Click
OK.

Copying Home Stack Button to Other Cards

We’ll be copying the Home Stack button and pasting it onto two other cards.

qq Change to the Edit (Arrow) tool, and click the Home Stack button you have
added. Choose Copy Button from the Edit menu.
qq Move to Card 3 and choose Paste Button from the Edit menu. The button
will be placed at the same location as on Card 2.
qq Move to Card 1 and choose Paste Button again. Adjust the position of the
button so it covers the corner of the sheet of paper on Card 1.
qq Save your stack.
Congratulations! You have completed your first project! Move back to Card
one and click through your stack. You might want to create buttons which
move back to previous cards, or add some artwork with the paint tools. You
now know the core set of skills that most people use in creating HyperStudio
projects.
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Chapter 4

Advanced
Techniques
In this Chapter:
¬¬
¬¬
¬¬

Basic Procedures
More Ideas!
A User Might Like to Know

HyperStudio 5

Once you are comfortable with the basic HyperStudio skills, you
should spend some time exploring this chapter. There are instances
where you can combine several simple elements to create very
impressive effects. Simple to use should not be confused with lack of
depth and sophistication!
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Basic Procedures
Creating a Layered Animation With Graphic Objects

One of the more powerful features of HyperStudio’s animation system is its
ability to animate in front of or behind objects. In this instance, we want an
animation to take place behind an object. The important thing to remember is that
graphic objects float over the card on another layer. Painted text or any selected
area can be turned into graphic objects. Keeping this in mind, you can imagine an
animation that could pass behind objects on the screen, yet pass in front of painted
areas of the card.

Basic Procedure:

1. Draw some simple artwork or lettering on the card.
2. Lasso the portions of the artwork or letters behind which you want to
make the animation pass.
3. When the dotted line surrounds the selected area, choose Convert to
Graphic Object from the Objects menu. This turns the selected area into
a graphic object.
4. Create a button, and create an animation to move something across the
screen. Release the mouse button to stop recording the animation path.
5. In the Path Options pane, deselect the “Float over” checkbox and click
OK.
6. Select the Browse tool in the Tools palette and click your button to test
it.

Using Painted Text Objects for Titles

It’s a good idea to use painted text objects for titles on your cards. This way you
can manipulate titles on top of a busy background or photograph. You can also
have them outlined.

Basic Procedure:

1. In the Tools palette, drag the mode slider to the right to enter Objects
mode.
2. Click the Text tool and specify settings for it in the Tools drawer. You
can open or hide the drawer by clicking the arrow at the bottom of Tools
palette, or by double-clicking the tool you want to use.
3. Type some text with the Text tool.
If you have typed text in Background mode, you can turn painted titles into
graphic objects. Encircle the text with the lasso. (This will surround each letter of
the text with the dotted line.) Then choose Convert to Graphic Object from the
Objects menu.

Create Graphics with Actions

Graphic objects can have actions associated with them. This is more efficient than
the alternative of drawing an image and then creating an invisible button over it.
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Basic Procedure:

1. Add a graphic object from the HyperStudio Library or from your hard
disk. If you have drawn something on the background, select the graphic
you want to use with either the Square Selector tool, the Circle Selector
tool, or the Lasso, and then choose Convert to Graphic Object from the
Objects menu.
2. In the Inspector, click Actions to go to the Actions pane. Select the
actions you want to associate with your graphic.

Play Movies in Interesting Shapes

Since graphic objects float over the card’s background, and since graphic objects
can be any shape, they can be placed over square movies to hide their corners,
making it seem as though the movie itself is an irregular shape.
We will turn the selected image into a stencil with the irregular shape being the
transparent hole.

Basic Procedure:

1. Select the area that you want to use as the shape of your movie, and
make it white, using paint tools. It must be white because whatever color
you start the lasso selection on becomes the transparent color for the
selected area. The card is white, so the selected shape must also be
white.
2. Using the Lasso tool, encircle the entire image starting from the white
area of the background.
3. When you see the dotted line, choose Convert to Graphic Object from
the Objects menu.
4. Create a button which will play a movie. Deselect the “Play over objects”
option in the Inspector for the “Play a movie or video” action.

Tricks With Transitions: Revealing Text

You already know that transitions are the special effects that you see when going
from one card to another. You can use a Wipe Right transition to reveal a new line
of text at each click of the button!

Things Appearing Magically

By creating two cards with the same background and then adding some new
things to the second card, you can make those things seem to appear magically by
using the Fade transition.

Easy Animations with Transitions

To create a rising curtain or window shade effect, use the Wipe Up or Slide Up
transitions. If the two cards are nearly identical, with one showing a curtain
up and the other with a curtain down, the transition will give the illusion of a
computer animation.

HyperStudio 5
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More Ideas!
Cookie Cutters & Copiers

For this trick, imagine a word written with paint text or a solid shape. Now
imagine picking up a pattern from a picture so that the letters are written in that
pattern, or the shape is filled with that pattern. To do this, we have to create a card
with a pattern on it. We also need a working card to create our text on. What we’ll
do is lasso the text, copy it, and bring it over to the pattern. We’ll then pick up the
pattern from the first card.

Basic Procedure:

1. Type your title in a bold, chunky font using the Text tool in Background
mode.
2. Create a new card and add an appropriate background (a gradient,
photograph, or tiling of a small image).
3. Move to the title card.
4. Lasso the title.
5. Copy it.
6. Move to the card with the imported background by pressing Command-.
(period). Note, you should have the Lasso tool active before pasting the
selected text.
7. Paste the title, but do not click away from the dotted line.
8. From the Edit menu, choose Effects and select Cookie Cutter. You will
know that you will be successful if the letters become transparent within
the dotted line. Press Command-C to copy the new text on the new
background.
9. Move back to your title card and paste the new title. Don’t worry about
the dotted line on the other card.
10. Drag the new title just slightly above and to the left of the original title,
creating a drop shadow.

Erasing Text in GhostWriter

GhostWriter is a neat action that will automatically “type” words into a text
object. An approach to erase all the text written by GhostWriter is to use the
TextMover action to move the contents of an empty text object into the place
where GhostWriter just “wrote”. This is usually done by a button that moves to
the next card, but can be done with any button that serves your purpose.

Basic Procedure:

1. Create the Scroll Box Text object that you want the text to appear in, and
give it a specific name, like “MyMessage”.
2. Create a button that uses GhostWriter to make your text appear. Read
the GhostWriter information window at the More Button Actions dialog
for more information.
3. Create an empty Scroll Box Text object somewhere else on that card or
in your stack (at the end of the stack is a good place) named “Empty”.
In the Features pane of Inspector, select the Hidden checkbox. In Edit
mode, the placeholder text will be visible, but it will disappear when you
switch to Browse mode.
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4. Make a button that goes to the next card. Also select More Button
Actions and select the TextMover action. In the Inspector pane for
TextMover, you need just choose the Empty text object in the Source
pop-up menu and the MyMessage text object in the Destination pop-up
menu.

When the button is clicked to go to the next card, it will also erase the text from
the MyMessage box by moving the empty contents of Empty into it!

HyperStudio 5
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A User Might Like to Know
“Sharing” a Background Using Group Cards

If you want to use the same background on lots of cards and still keep your stack
size small, you can use Group Cards. See the Reference Guide for information
about using group cards.

Refreshing a Card

If you create a button which connects to another card, and you choose the same
card you are on, HyperStudio will restore the original appearance of the card. This
effect would be good for a card which plays a frame animation. The “reset” button
could cause the animation to disappear, making the card ready for the next user. If
you had scrolling text object that had been scrolled down, it would be reset back
to the top as well.

Setting the Text Color of a Button

When a button is selected, use the “Name” color well in the Appearance pane of
the Inspector to set the color of the text on the button.

Setting the Color of the Text and Background Within a Text
Object

If you select an entire text object with the Arrow tool, choosing a text color in the
Appearance pane of the Inspector will set the color for all the text in that object.
To change background color, use the “Background” color well. Note: To be able
to change the background of a text object, you need to select the Scroll Box Text
option and make sure that the Background checkbox is selected in the Appearance
pane of the Inspector.

Shortening a Shape in Background mode

If you have a rectangular shape (for example, a rounded solid border around a
blank interior) on a card background, you can shorten the shape as needed. To
shorten it (either vertically or horizontally), just use the Square Selector tool to
select the horizontal or vertical half of your shape. Then slide the selected image
back on top of the other half of the existing graphic. The effect will be to make
the shape a little shorter.

Lengthening a Shape in Background mode

To make a graphic longer, hold down the Option key when you press the mouse
button to start dragging the selected region. This will make a copy that, when
overlaid with a slight offset, will extend the graphic. Both these techniques are
similar to what you would do with wallpaper when trying to fit a specific-sized
area. This is a little difficult to describe with words, but is pretty easy to grasp
if you try it. Experiment a little and you’ll probably be able to see what we’re
talking about.
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Transparent Text Objects

You can deselect “Background” for a Scroll Box Text object in the Appearance
pane of the Inspector. Text objects without background fill allow you to see
through them, so that the background underneath is visible. Deselect this option
when you want text showing over a card’s background.

Color Replace

This is a handy effect that will manipulate all the color pixels in any selected (lasso,
circular, or rectangular) area or graphic. Having selected part of the graphic background
or object, just choose Effects and then Image Effects from the Edit menu. One of the
options is “Replace Colors”. You can either replace all occurrences of one color with
another, or swap two colors. Replacing is an easy way to change, for example, a green
arrow into a blue arrow without having to use the fill tool or the magnifying glass. The
exchange color option can quickly “invert” an image. For example, swap black and
white (or a light/dark color pair) for an interesting effect.

Pop-Up Objects

On some occasions, you may wish you could have an image “pop up” on a card
when a button is pressed. There are several ways to do this. One of them — the
“brute force” method is to just create a second card that looks identical to the
first, except that it has an additional text object, graphic object, or whatever on it.
A button on the first card then moves to the second, without transition effect, to
create the “pop-up” effect. Another button can move back to the first card to make
the pop-up item disappear. Be sure to turn off the “Show card number with stack
name” option in Preferences to maximize this pop-up effect.

Another approach is to add a word or image, etc. that you want to pop up (it can
be painted on the card’s background or added as floating object). What you are
creating is essentially a one-frame animation. Now, create a button, and have it
perform an animation. Click “Part of the Card,“ click “Lasso,” and then select the
image so that only the item you want appears at the desired location on the screen.
For floating objects, click the Selectable Object button and click the object you
want to pop-up. After that, click the place where the pop-up object should appear.
Make sure that “Erase when done” and “Show first frame” are not selected, and
choose a transparent color if necessary. Click OK, and then erase the original
image or delete the object you have used for animation. The advantage of oneframe animation pop-ups is that they are very fast. To make the image go away,
create a button that moves to another card, but actually just moves to the original
card. This effect will refresh the original screen, thus erasing the pop-up item. You
can combine multiple buttons, each with a pop-up graphic for very interesting
effects. For example, imagine a “Mr. Potato Head” where you add different parts
using pop-up objects.
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Chapter 5

Ask
Addy

In this Chapter:
¬¬

I’d Like To ...

HyperStudio 5

Not sure about the way to do something? Perhaps Addy can help you.
Even if you are an experienced HyperStudio user, you might pick up a
useful tip in this section.
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I’d Like To ...
Know what a stack is:

¬¬
¬¬

A stack is series of cards. The cards can be linked together with buttons (hot
spots on the screen where you can click the mouse to make things happen).
On these cards you can add buttons, text, animations, graphics, and sounds,
as well as show movies and play live video. Try the tutorial, which will take
you through making your first stack.

Start my own stack:

¬¬

To begin a new stack, choose New Stack from the File menu. A new card
with a white background will appear.

Know how many cards I should put in a stack:

¬¬

It’s a good idea to use buttons to link lots of little stacks together rather than
creating one giant stack. Try making 10 to 15 the maximum number of cards
in a stack. If you were writing a book, you’d split it into chapters, so why not
divide your projects into smaller stacks?

Look at a stack I’ve already saved:

¬¬

Choose Open Stack from the File menu. You’ll see the contents of the
Documents folder or the folder where you saved your stack last time. It’s a
good idea to create a folder where you keep your own stacks. If your stack
is saved on the Desktop, choose Desktop on the left side of the window, and
then select your stack.

Remove a button:

¬¬

To delete a button you have to select it with the Arrow tool
is selected, press the Delete key.

. Once it

Fix a graphic which was pasted with a white square around it:

¬¬

If you have selected your graphic with the Square Selector tool
, rather
than the Lasso tool
, then you will take the rectangle drawn with the
Selector tool as well. You can always use the Paint Bucket Fill tool
to
fill in this white space with the color of your background. If you are adding a
graphic to a background with lots of artwork on it already, then use the Lasso
tool
.

Know how to show the Tools palette:

¬¬

If you have accidentally closed the Tools palette, choose Show Tools from
the Window menu to see it again.

Erase something drawn with a paint tool or written with the
Text tool in Background mode:

¬¬
¬¬
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Use the Eraser tool

set to the same color as the background, or

Do fine erasing using the magnifier to zoom in on a selection, or
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¬¬

Select an area with the Square Selector tool
key.

and then press the Delete

Take text from one card and put it somewhere else:

¬¬
¬¬

That’s called cutting and pasting. Select the text object with the Arrow tool.
Choose Cut Text Object from the Edit menu. Create a new card. Choose
Paste Text Object from the Edit menu.
If you only want to cut and paste part of the text, that is also possible.
Double-click the text object in Edit mode and select the text you want by
dragging the cursor across the words. Choose Cut from the Edit menu.
Double-click in the text object you want to paste into. Choose Paste from the
Edit menu. Remember, the Square Selector tool
is used for selecting
artwork or painted text, while the Arrow tool
is for selecting
buttons, text objects, and graphic objects. You can also use the Browse tool
to select a portion of text that you want to cut or copy from a text
object, provided that it is a Scroll Box text object and does not have the
“Read only” option selected.

Find my buttons — they are invisible and I can’t see them:

¬¬

Press the Option key and the ⌘-key at the same time when you are in
Browse mode. You’ll see your invisible buttons! If you don’t want people to
be able to see your invisible buttons, then lock your stack.

Know more about the RollCredits action:

¬¬
¬¬

You don’t need to enter the name of the text object unless you have more
than one text object on the card. If there is only one text object on the card,
RollCredits will automatically find it.
The total scroll rate is the number of pixels per scroll times the number of
steps per second. This means that 3 pixels at 10 steps per second is the same
as 1 pixel at 30 steps per second.

Make a sound loop (play a sound over and over):

¬¬

Create a button which plays a sound. Choose the sound file and select the
“Loop sound” checkbox.

Have sound on a card:

¬¬

Make a button! In the Actions pane of the Inspector, choose “Play a sound”.
Buttons can do things without having connections to other cards.

Play two sounds at the same time. What I have in mind
was some music playing and a recording of my voice
announcing the title of my stack:

¬¬

HyperStudio 5

I’m glad you asked! Sure you can do it! When you get to the “Play a sound”
action pane, you will see an option called Background sound. A background
sound will keep on playing regardless of whether you start a second sound.
If you record your music as a background sound and your voice as a regular
sound, this will work!
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